Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Configuration > Archive > ACTIVESYNC (fails online tests with incorrect XML response)

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon Configuration  / Archive  /

ACTIVESYNC (fails online tests with incorrect XML response)

[Griffin, Ashley]
Ashley Griffin
Newbie
Newbie
Posts: 35
Ashley Griffin - 10:41pm, Apr 23 2017

Hi

I have setup many Microsoft Exchange servers in my time with SSL and correctly working ActiveSync services.

To test them i use this site https://testconnectivity.microsoft.com/ which is a highly detailed output of any DNS, SSL or other issues with regards activesync (it does many other tests but i mostly use it to confirm activesync problems).

I can get it to find the MDaemon server via the DNS SRV record method, but its failing on the XML response from the server, the MDaemon server doesnt seem to be serving an XML formatted response that activesync likes, does it need configuring?

Many Thanks

  (older msg: 1)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Ashley Griffin - Apr 24, 2017 11:23 am (#2 Total: 4)  

 

Photo of Author
Ashley Griffin
Newbie
Newbie
Posts: 35
Hi

We dont see any errors with regards the authentication of the service, its the contents of the XML record..

As an overview to the method we use for ActiveSync, as there can be multiple domains using a single server, this can sometimes create a little nightmare with ActiveSync and the SSL name on the certificate, so we always use the DNS record SRV with _autodiscover._tcp.domain.com (for the local domain), this record then POINTS to the server real name with using the SSL certificate and works with ALL versions off Outlook not having SSL name issues when auto configuring email as its the redirect method, please see below (ive used different domain names for this example):

SERVER : mail.domainhosting.com
SSL : mail.domainhosting.com

Email to use : test@domain1.com
DNS SRV record : _autodiscover._tcp.domain1.com
DNS SRV contents : target = mail.domainhosting.com, weight = 10, priority = 10, port = 443

To test the above we would use
https://testconnectivity.microsoft.com : Exchange ActiveSync Autodiscover

Email address : [use the real one]
Domain user name : [use what ever username you use to access your account in MDaemon, we use the full email address]
Password : [One used for MDaemon above email address]
Ignore test for SSL : Do not tick this

Run the test, ive listed my error below (masked a few parts not wanted to be seen on the internet)
Can see it doesnt like the response, not that it didnt need to login, its the contents of the XML....

Attachments:

test.jpg (453 KB) (403 Downloads)


Arron Caruth (apparently) - Apr 25, 2017 11:06 am (#3 Total: 4)  

via email  

Photo of Author
Arron Caruth
Administrator
Administrator
Posts: 1700

We are intentionally responding with a document that can be displayed by the browser.  This makes it easier for admins to determine if the AutoDiscover service is setup and working correctly.

 

It should not prevent any email clients from using the autodiscover service.

 

-- 

Arron Caruth
Director of Product Development
Alt-N Technologies
http://www.altn.com
 

Sent using Alt-N's own MDaemon Messaging Server   
Now available with  BYOD Mobile Device Management, 
Document Sharing, Hijacked Account Detection and more.

Get to know the Alt-N family by liking us on Facebook!

 

From: md-configuration@altn.com [mailto:md-configuration@altn.com] On Behalf Of Ashley Griffin
Sent: Monday, April 24, 2017 11:24 AM
To: md-configuration List Member
Subject: [md-configuration] ACTIVESYNC (fails online tests with incorrect XML response)

 

Hi

We dont see any errors with regards the authentication of the service, its the contents of the XML record..

As an overview to the method we use for ActiveSync, as there can be multiple domains using a single server, this can sometimes create a little nightmare with ActiveSync and the SSL name on the certificate, so we always use the DNS record SRV with _autodiscover._tcp.domain.com (for the local domain), this record then POINTS to the server real name with using the SSL certificate and works with ALL versions off Outlook not having SSL name issues when auto configuring email as its the redirect method, please see below (ive used different domain names for this example):

SERVER : mail.domainhosting.com
SSL : mail.domainhosting.com

Email to use : test@domain1.com
DNS SRV record : _autodiscover._tcp.domain1.com
DNS SRV contents : target = mail.domainhosting.com, weight = 10, priority = 10, port = 443

To test the above we would use
https://testconnectivity.microsoft.com : Exchange ActiveSync Autodiscover

Email address : [use the real one]
Domain user name : [use what ever username you use to access your account in MDaemon, we use the full email address]
Password : [One used for MDaemon above email address]
Ignore test for SSL : Do not tick this

Run the test, ive listed my error below (masked a few parts not wanted to be seen on the internet)
Can see it doesnt like the response, not that it didnt need to login, its the contents of the XML....

Attachment: test.jpg


View/reply at ACTIVESYNC (fails online tests with incorrect XML response)

 
 
--MD-Configuration---------------------------------------------------
This list is for questions about the configuration of MDAEMON. To 
unsubscribe from this mailing list send an email to 
md-configuration-unsubscribe@altn.com .
--POWERED BY MDAEMON!------------------------------------------------
 
---------------------------------------------------------------------
These forums are provided by Alt-N Technologies for user-to-user 
support and discussion.  Alt-N staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------

--MD-Configuration---------------------------------------------------
This list is for questions about the configuration of MDAEMON. To
unsubscribe from this mailing list send an email to
md-configuration-unsubscribe@altn.com .
--POWERED BY MDAEMON!------------------------------------------------

---------------------------------------------------------------------
These forums are provided by Alt-N Technologies for user-to-user
support and discussion.  Alt-N staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
http://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------

Darwin Brewer - Mar 16, 2020 6:51 pm (#4 Total: 4)  

 

Photo of Author
Darwin Brewer
Newbie
Newbie
Posts: 1
Did you ever figure this out? I am having the same problem.



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.