Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Content Filter > Copying message to 2 mailing lists gives "User unknown"

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon Content Filter  /

Copying message to 2 mailing lists gives "User unknown"

Hi everyone

Task: redirect specific sender/recipient messages to 2 local mailing lists.
Following CF rule

[Rule001]
RuleName=REDIRECT Particular Sender/Recipient -> [test list] & [test list 1]
Enable=Yes
ThisRuleCondition=All
ProcessQueue=LOCAL
Condition01=FROM|contains|OR|sender@domain.com|
Condition02=To|contains|AND|recipient@my_domain.com|
Action01=copy to|"test_list@my_domain.com","test_list_1@my_domain.com"
Action02=delete|

correctly redirects message to test_list_1 users, but produces Users
unknown error for the test_list log details in the bottom).
Both test_list@my_domain.com and test_list_1@my_domain.com are valid
mailing lists.
I've tried a few combinations and it is always the first list in the
Action line which gets rejected.
After some more testing I've found out that changing actions to

Action01=copy to|"test_list@my_domain.com"
Action02=copy to|"test_list_1@my_domain.com"
Action03=delete|

works as it should. But it requires manually editing CFRules.dat

  ----------
  Content Filter processing e:\mdaemon\queues\local\md50000146571.msg...
  * Message return-path: sender@domain.com
  * Message from: sender@domain.com
  * Message to: recipient@my_domain.com
  * Message ID: <83ce8313-ac49-5e5b-31c5-4985abd252f1@domain.com>
  Start Content Filter results
  * Message matched rule: 001 "REDIRECT Particular Sender/Recipient ->
[test list] & [test list 1]" (Hits: 1)
  * Condition: From header contains [sender@domain.com]
  * Condition: To contains [recipient@my_domain.com]
  * Action: Message copied to user(s)
  * Matched 1 of 10 active rules
  End of Content Filter results
  ----------
  ----------
  LOCAL message: pd50000146572.msg
  * From: Sender <sender@domain.com>
  * To: recipient@my_domain.com
  * Subject: Test message 01
  * Message-ID: <83ce8313-ac49-5e5b-31c5-4985abd252f1@domain.com>
  * Unknown local user <test_list@my_domain.com>
  * Message <e:\mdaemon\queues\local\pd50000146572.msg> routed back to
sender
  ----------

Is this just me?


Regards

  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Tyler Davis - Aug 27, 2019 9:23 am (#1 Total: 1)  

Alt-N Technical Support  

Photo of Author
Tyler Davis
Frequent
Frequent
Posts: 259

MDaemon
RelayFax
SecurityGateway
Outlook Connector
SecurityPlus
ProtectionPlus
WebAdmin
This is a bug that our developers are aware of and are looking into. Your work-around is correct if you'd like to use this rule. If you'll be creating rules like this in the future, you can also create two rules in the GUI. This would not require you to edit the cfrules.dat file.

--
Tyler Davis
MDaemon Technologies
https://www.mdaemon.com

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user
support and discussion. MDaemon staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
http://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.