Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon WorldClient Issues > Archive > WCAPI - Authentication failure: AuthRefused - Fixed by disabling Dynamic Screening

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon WorldClient Issues  / Archive  /

WCAPI - Authentication failure: AuthRefused - Fixed by disabling Dynamic Screening

[Cramp, Edmund]
Edmund Cramp
Novice
Novice
Posts: 239

MDaemon
Outlook Connector
WebAdmin
Edmund Cramp - 01:07pm, Dec 15 2020

I am unable to log in to user email account via the webserver interface from outside:

Tue 2020-12-15 11:46:55.718: BeginRequest WCAPI POST /WorldClientAPI/authenticate/basic
Tue 2020-12-15 11:46:55.721: WCAPI - Authentication failure: AuthRefused. (172.58.155.150)
Tue 2020-12-15 11:46:55.721: EndRequest WCAPI POST /WorldClientAPI/authenticate/basic (Request Took: 0.004500 seconds)

I've checked the SSL certificate and it's good, the Dynamic Screening blacklist is empty, and I can login as the administrator, but not as a user. I tried resetting all auth failure data and all blacklist data but it doesn't fix it even after a reboot.

So I turned off the Dynamic Screening Service - and now everything is working.

  (older msg: 8)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Edmund Cramp - Dec 18, 2020 11:01 am (#9 Total: 11)  

 

Photo of Author
Edmund Cramp
Novice
Novice
Posts: 239

MDaemon
Outlook Connector
WebAdmin
Replying to: Jonathan Ehman (Dec 18, 2020 10:43 am)
Hi Edmund,   After reviewing the logs, I cannot see where Dynamic Screening has blocked your IP, but it's clear...

I can do some diagnostics, I think that the IP screening may be the cause because I was trying to log into the same account via the VPN that is used by multiple copies of Outlook in the office. So the IP screening might have been doing the job that it was designed to do.

I was thinking originally that the screening issue was the same cause of issues that a website designer is having because he can't get his cloudflare site to send emails but I've discovered that his cloudflare DNS has problems.

I need to turn Dynamic Screening back on - I'm seeing an attempted logon every 20 seconds now.

Edmund Cramp - Dec 18, 2020 11:36 am (#10 Total: 11)  

 

Photo of Author
Edmund Cramp
Novice
Novice
Posts: 239

MDaemon
Outlook Connector
WebAdmin
I turned Dynamic screening back on and I can't log in via the VPN any more. Initially I thought that this was because the IP screen was tracking the domain that I was logging into and had been able to access with the VPN when screening was turned off, when I turned the screening back on I'm blocked again.
So I created a new domain and account and tried logging in for the first time via the VPN and it's blocked again but the VPN IP address is not shown in the dynamic screening log.

Edmund Cramp - Dec 18, 2020 4:24 pm (#11 Total: 11)  

 

Photo of Author
Edmund Cramp
Novice
Novice
Posts: 239

MDaemon
Outlook Connector
WebAdmin
I turned Dynamic screening on and the VPN could no longer access the mail server so I disabled the location screening - that seemed to have fixed it. The VPN terminates in Dallas, TX and all the geo-locations identify the IP as being in Dallas, TX but the location details seem to be thinking that the IP address (45.132.115.14) belongs to a variety of owners, including one in Australia.

So then I turned Location Screening back on (and lost access again) but fixed the issue by added the IP address to the Security Settings - Trusted IP list. The odd thing is that I could not find anything in the location screen logging to indicate that the IP was being blocked.

[Last Editor: Edmund Cramp, Dec 18, 2020 4:27 pm. Total Edits: 1]



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.