Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Support > Archive > Debug iOS connectivity options?

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon Support  / Archive  /

Debug iOS connectivity options?

I have a user w/ an iPhone 8. After upgrading to 19.5 his phone stopped working. It was connected via activesync/exchange. After the update I removed the domain in his configuration and it no longer appears to connect.

I have change password. Removed/readded him to ActiveSync. Rebooted his phone. Reset Network Settings on his phone. Updated to latest version. I have tried to login as me. IMAP works ok. CalDAV and Exchange options do not work. I tried on Wifi and on his cell service. IMAP seemed to not be able to confirm that the settings were correct and I needed to "Save Anyway" - but it works.

Here is the rub: I have other users working ok at the moment. Because it is just his phone I have to think it is his phone and not his account or anything like that. However: His phone was working prior to the update to 19.5. His access to other calendars and accounts appear to be functioning without issue.

So it REALLY feels like something is wrong with his phone BUT it only started once I updated to 19.5? Coincidence perhaps?

I am wondering if there are any suggested steps to debug connectivity from his device to the servers. ActiveSync and CalDAV are all running on IIS.

Thanks!!

  (older msg: 9)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Jim Aguiar - Nov 11, 2019 1:08 pm (#10 Total: 15)  

 

Photo of Author
Jim Aguiar
Newbie
Newbie
Posts: 73
Yes, and I responded telling you that removing the domain fixed the issue.

In this particular case I have a single user with an issue I can't pin down.

Arron.Caruth@mdaemon.com - Nov 11, 2019 1:31 pm (#11 Total: 15)  

Guest User  

Photo of Author
Posts: 1

I’m sorry, I must be confused about what is going on.

 

You have a single device that is unable to login correct?  The log snippet shows a 403 forbidden response being returned, correct? 

 

Please send a copy of all of the .DAT and .INI files from the MDaemon\app directory and from the MDAemon\data directory. Also, please zip your MDaemon\Logs directory for the most recent day the issue has been reproduced.

 

In addition to this information, please let me know the email address the device is trying to login to along with Device ID of the device trying to connect via ActiveSync

 

Please send the information directly to my email address (found in my signature), do NOT post it to the list.

 

--
Arron Caruth
Vice President of Product Development
o: 817-601-3222    e: Arron.Caruth@mdaemon.com

MDaemon Technologies
Simple Secure Email
Visit us on www.mdaemon.com | Facebook | LinkedIn | YouTube
Sent using the MDaemon Email Server

From: md-support@mdaemon.com [mailto:md-support@mdaemon.com] On Behalf Of Jim Aguiar (lists-md-support@mdaemon.com)
Sent: Monday, November 11, 2019 12:09 PM
To: md-support@altn.com
Subject: [md-support] Debug iOS connectivity options?

 

Yes, and I responded telling you that removing the domain fixed the issue.

In this particular case I have a single user with an issue I can't pin down.


View/reply at Debug iOS connectivity options?

 
 
--MD-SUPPORT--------------------------------------------------------------
This list is for questions and discussion about MDAEMON. To unsubscribe 
from this mailing list send an email to md-support-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!-----------------------------------------------------
 
--------------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/Support/RequestSupport/
--------------------------------------------------------------------------

--MD-SUPPORT--------------------------------------------------------------
This list is for questions and discussion about MDAEMON. To unsubscribe 
from this mailing list send an email to md-support-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!-----------------------------------------------------

--------------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/Support/RequestSupport/
--------------------------------------------------------------------------

Jim Aguiar - Nov 15, 2019 9:45 am (#12 Total: 15)  

 

Photo of Author
Jim Aguiar
Newbie
Newbie
Posts: 73
Thank you Arron.

I have confirmed it is device-specific. I have tried several known-good accounts and continue to get the 403/prohibited.

I have several devices where this is happening. This appears to be User-Agent=Apple-iPhone10C1/1702 devices.

User-Agent=Apple-iPhone10C1/1607 appears to be working without issue. It appears that upgrading to MD 19.5 AND an iPhone 8 upgraded to 13.* seems to be to able to connect to AS using Exchange or CalDAV.

I just updated a device to 13.2.2 and no change.

MORE:
It is a little more complicated, apparently. A user that was working yesterday is now not working today. He was having a sync issue yesterday, I had him turn the Calendar switch off and back on. Then this morning he seemed to have an issue again, so I removed his client entry from the domain to force a refresh on the device and that seems to have caused the issue.

User-Agent=Apple-iPhone10C1/1702.102 yesterday, showing good. Today I went to AS->Domain Management->Clients->Removed him, he re-sync'd and started seeing the error. Unlike the first user, though, he popped back up on the list. But the AS logs are showing him as 403/Forbidden: Access Denied too.

This is odd.

I am feverishly trying to get these guys their schedules. Will send you the requested logs shortly.



  (newer msg:3)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.