Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon API > New accounts added by xmlAPI will not inherit settings from "new Accounts" template

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon API  /

New accounts added by xmlAPI will not inherit settings from "new Accounts" template

When adding new accounts through the xmlAPI I can't seem to get the settings I want for "Remote Administration" settings. Specifically edit password so the user can change to a different password than the one we create for them.

My first assumption was that ALL new accounts inherited these settings.

I tried to include them in the request (see example) but still no luck.

The account gets created and has some settings per the default template but not the ones I need.

this is my request and response:

--- [Start request] ------------------------------------------------------------+
 > Logging in ...
 > sending ...
////////////////////////////////////////////////////////////
<?xml version="1.0" encoding="utf-8"?><MDaemon><API><Request encoding="utf-8" version="19.5.0" echo="1" verbose="1">
    <Operation>CreateUser</Operation>
        <Parameters>
            <Domain>mxxxx.com</Domain>
<Mailbox>spip20</Mailbox>
<Details>
<FullName>spip20</FullName>
<Frozen>No</Frozen>
<Disabled>No</Disabled>
<MustChangepassword>No</MustChangepassword>
<DontExpirePassword>Yes</DontExpirePassword>
<Password>XXXX</Password>
</Details>
</Parameters>
    <RemoteAdmin>
<Enabled>1</Enabled>
<EditFullname>1</EditFullname>
<EditPassword>1</EditPassword>
<EditFwd>1</EditFwd>
<EditAutoResponder>1</EditAutoResponder>
<EditImapRules>1</EditImapRules>
</RemoteAdmin>
</Request></API></MDaemon>

////////////////////////////////////////////////////////////
--- [Debug response] ------------------------------------------------------------+
 > recieving ...1459 bytes
////////////////////////////////////////////////////////////
<?xml version="1.0" encoding="utf-8"?>
<MDaemon>
<API>
<Request encoding="utf-8" version="19.5.0" echo="1" verbose="1">
    <Operation>CreateUser</Operation>
        <Parameters>
            <Domain>mxxxx.com</Domain>
<Mailbox>spip20</Mailbox>
<Details>
<FullName>spip20</FullName>
<Frozen>No</Frozen>
<Disabled>No</Disabled>
<MustChangepassword>No</MustChangepassword>
<DontExpirePassword>Yes</DontExpirePassword>
<Password>XXXX</Password>
</Details>
</Parameters>
    <RemoteAdmin>
<Enabled>1</Enabled>
<EditFullname>1</EditFullname>
<EditPassword>1</EditPassword>
<EditFwd>1</EditFwd>
<EditAutoResponder>1</EditAutoResponder>
<EditImapRules>1</EditImapRules>
</RemoteAdmin>
</Request>
<Response version="19.5" session="18301082" et="10.106285">
<Status id="0" value="0x00000000" message="The operation completed successfully."/>
<ServiceName>Management Web Service (64bit) for MDaemon Messaging Server</ServiceName>
<ProductVersion>19.5.0</ProductVersion>
<ServiceVersion>19.5.0.5</ServiceVersion>
<SERVER_NAME>XXXX</SERVER_NAME>
<DOMAIN>XXXX</DOMAIN>
<URL>/MdMgmtWS/</URL>
<AUTH_USER>XXXX</AUTH_USER>
<TimeStamp>2019-10-15T10:55:18.000Z</TimeStamp>
<Uptime>16 days 4 hours 41 minutes 50 seconds</Uptime>
<Operation>CreateUser</Operation>
<Result>
<User id="spip20" displayname="spip20" domain="mxxxx.com"/>
</Result>
</Response>
</API>
</MDaemon>
////////////////////////////////////////////////////////////

any assistance would be appreciated

  (older msg: 7)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Arron.Caruth@mdaemon.com - Dec 9, 2019 5:06 pm (#8 Total: 9)  

Guest User  

Photo of Author
Posts: 1

Thank you for the additional information.  I found the issue and have submitted it to the developers for further review.

 

For now, you can work around it by editing the MDaemon.ini file and deleting the following key from the [Public Folders] section:

 

EnablePublicFolders=No

 

Once you’ve made the change, save the file and restart MDaemon.

 

MDaemon defaults to public folders being disabled, so this won’t enable the public folders, but it will allow you to work around the bug in the XML API.

 

--
Arron Caruth
Vice President of Product Development
o: 817-601-3222    e: Arron.Caruth@mdaemon.com

MDaemon Technologies
Simple Secure Email
Visit us on www.mdaemon.com | Facebook | LinkedIn | YouTube
Sent using the MDaemon Email Server

From: md-api@mdaemon.com [mailto:md-api@mdaemon.com] On Behalf Of Patrik K (lists-md-api@mdaemon.com)
Sent: Monday, December 9, 2019 10:52 AM
To: md-api List Member <md-api@mdaemon.com>
Subject: [md-api] New accounts added by xmlAPI will not inherit settings from "new Accounts" template

 

I have sent you an email with an attached zipfile containing the requested files.


View/reply at New accounts added by xmlAPI will not inherit settings from "new Accounts" template

 
 
--MD-API-------------------------------------------------------------
This list is for questions and discussions regarding MDAEMON's API.
To unsubscribe from this mailing list send an email to
md-api-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!------------------------------------------------
 
---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/support/request_support.asp
---------------------------------------------------------------------

--MD-API-------------------------------------------------------------
This list is for questions and discussions regarding MDAEMON's API.
To unsubscribe from this mailing list send an email to
md-api-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!------------------------------------------------

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/support/request_support.asp
---------------------------------------------------------------------

Patrik K - Dec 11, 2019 7:51 am (#9 Total: 9)  

 

Photo of Author
Patrik K
Newbie
Newbie
Posts: 6
We have a service window this Thursday night, I will remove the "EnablePublicFolders=No", restart the server and get back to you with the result.

Thank you for your assistance so far.



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.