Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon API > Error On UpdateUser Operation for forwarding

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon API  /

Error On UpdateUser Operation for forwarding

[Mclaughlin, John]
John Mclaughlin
Newbie
Newbie
Posts: 7
John Mclaughlin - 10:12am, Mar 8 2020

I am receiving the following error when using the UpdateUser operation to update forwarding.

W_MMWS_NOT_A_VALID_FORWARDING_ALIAS

The forwarding seems to be setup so I am wondering why I am receiving this error.

  (older msg: 2)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Keith Personett (apparently) - Mar 8, 2020 11:08 am (#3 Total: 4)  

via email  

Photo of Author
Keith Personett
Newbie
Newbie
Posts: 76

Are you specifying a Forwarding/SendAs element in your XML?

 

That should only be present if you are specifying an alias to forward as, instead of using the actual account email address.

 

If not, then it’s a red herring that I will address in the API codebase.

 

FYI: I’ve just updated the API for MD 20 to reflect a more descriptive warning message.

 

The 'Forwarding/SendAs' value, "%1" is not a valid alias for this account.

 

Keith Personett

Senior Software Developer, Cerebro Calibration Specialist, Agent of S.H.I.E.LD., Helicarrier Systems Analyst

MDaemon Technologies http://www.mdaemon.com/ or on Facebook

Sent using Outlook 2013 via ActiveSync Services for MDaemon Messaging Server.

I 16 1018

"You get hurt, hurt 'em back. You get killed... walk it off!"

                - Steve Rogers/Captain America


--MD-API-------------------------------------------------------------
This list is for questions and discussions regarding MDAEMON's API.
To unsubscribe from this mailing list send an email to
md-api-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!------------------------------------------------

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user
support and discussion.  MDaemon staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
http://www.mdaemon.com/support/request_support.asp
---------------------------------------------------------------------

Replies to this message
  • John Mclaughlin (Mar 8, 2020 11:43 am)


  • John Mclaughlin - Mar 8, 2020 11:43 am (#4 Total: 4)  

     

    Photo of Author
    John Mclaughlin
    Newbie
    Newbie
    Posts: 7
    Replying to: Keith Personett (Mar 8, 2020 11:08 am)
    Are you specifying a Forwarding/SendAs element in your XML? That should only be present if you are specifying an alias to...

    I was sending an </sendas> remove this solved the problem.

    Thanks you very much for quick responses.



      All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



     Content:

    Read New | Search

     Guest:

    Email to Admin



    You are visiting as a Guest user.