Logout

Alt-N Discussion Groups > Outlook Connector Discussion Groups > Outlook Connector Support > Error when opening SMTP Stream

 [F] Alt-N Discussion Groups  / Outlook Connector Discussion Groups  / Outlook Connector Support  /

Error when opening SMTP Stream

[Burtovoy, Tony]
Tony Burtovoy
Novice
Novice
Posts: 188
Tony Burtovoy - 05:26pm, Oct 28 2020

Latest MDConnector(6.5.3), Latest MDx64(20.0.3).. although issue did occur on previous (20.0.2) as well. Server is Win 2016 Std x64.. plenty of RAM, plenty of disk.. 100% up to date on MS updates since about 2 weeks ago. Random Outlook users are getting this sort of error when sending mail:

"Error when opening SMTP stream"
  "TLS/SSL failure for MAIL.DOMAIN.COM: Unexpected TCP input disconnect"

Happens about once per week among all users. There are there (90 employees about 25 Outlook 2013 users). When the user gets the undeliverable but then tries again, it typically works just fine. Seems to be only Outlook and very random, but not webmail.

Here's what I seem to see in the server logfile (smtp-in) when this occurs:

Mon 2020-10-19 11:00:34.962: Accepting SMTP connection from 10.0.0.148:56569 to 172.24.16.115:465
Mon 2020-10-19 11:00:35.045: * SSL error 0x80090330 The specified data could not be decrypted.
Mon 2020-10-19 11:00:35.045: SMTP session terminated (Bytes in/out: 508/3730)

See attachment. Any ideas?

-Tony

Attachments:

Untitled.png (30 KB)


  (older msg: 1)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Tony Burtovoy - Nov 2, 2020 3:22 pm (#2 Total: 6)  

 

Photo of Author
Tony Burtovoy
Novice
Novice
Posts: 188
My apologies. Yes, 6.5.2. I must have been looking at "6.5.2 32-bit" and just melted the number together. oops!

No, nothing else in the logs besides what I have provided.

OK, umm.. well, I sort of assumed that the SSL/TLS stuff was handled by Mdaemon and the LetsEncrypt certfiicate, but maybe thats a wrong assumption. Is there something I need to turn on inside the operating system in Windows 2016? If i turn this on, will I have to re-install my LetsEncrypt certificate?

Please advise how I go about doing this?

Thanks
Tony B

Tyler Davis - Nov 5, 2020 4:17 pm (#3 Total: 6)  

Alt-N Technical Support  

Photo of Author
Tyler Davis
Novice
Novice
Posts: 205

MDaemon
RelayFax
SecurityGateway
Outlook Connector
SecurityPlus
ProtectionPlus
WebAdmin
MDaemon includes a process for obtaining a Let's Encrypt certificate and can be used to generate a self signed certificate.

http://help.altn.com/mdaemon/en/index.html?ssl_lets-encrypt.htm
http://help.altn.com/mdaemon/en/index.html?ssl_mdaemon.htm

MDaemon does not, however, control which protocols or ciphers are used. These can be enabled/disabled through registry edits or third party tools. I've used Nartec Software's IISCrypto application in the past with good results.

As long as the hostnames are note being changed, you shouldn't have to rebuild the Let's Encrypt certificate.

--
Tyler Davis
MDaemon Technologies
https://www.mdaemon.com

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user
support and discussion. MDaemon staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
https://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------

Parminder Singh - Mar 27, 2021 11:45 am (#4 Total: 6)  

 

Photo of Author
Parminder Singh
Newbie
Newbie
Posts: 6
so have you found a solution to your problem ???

Tyler Davis - Mar 30, 2021 9:04 am (#5 Total: 6)  

Alt-N Technical Support  

Photo of Author
Tyler Davis
Novice
Novice
Posts: 205

MDaemon
RelayFax
SecurityGateway
Outlook Connector
SecurityPlus
ProtectionPlus
WebAdmin
Parminder Singh, where you having issues with the "Error when opening SMTP stream" or the SSL/TLS issue or both? Do you have any more details on the issue that you're seeing?

--
Tyler Davis
MDaemon Technologies
https://www.mdaemon.com

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user
support and discussion. MDaemon staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
https://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------

Tony Burtovoy - Apr 8, 2021 8:40 am (#6 Total: 6)  

 

Photo of Author
Tony Burtovoy
Novice
Novice
Posts: 188
The issue has pretty much gone away - at least the users are not reporting any further issues - so I take that as an indication of success.

The only thing we did was have a consultant get into the registry to a particular key and make sure that all the common encryption protocols were present and configured (see screenshot).


Untitled



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.