Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon API > XML API for list management

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon API  /

XML API for list management

[BARTHES, Stephane]
Stephane BARTHE…
Newbie
Newbie
Posts: 5
Stephane BARTHES - 09:34am, Mar 12 2021

Hello,

I am looking into using the XML API to update sime mailing lists from our ERP.

If I understood properly, the UpdateList service only adds or Remove users. So I need to request the list of users in the ML to remove them and add the ones that should be subscribed?
Am I wrong on this one already ?

In order to get the current list of users, I tried the GetListInfo service, but which ever get I give, the response only contains the list name.

My request is like this :
(?xml version="1.0" encoding="utf-8"?)
(MDaemon)
(API)
(Request version="20.0.0" echo="1" verbose="0")
(Operation)GetListInfo(/Operation)
(Parameters)
(Domain)domainName(/Domain)
(ListName)testu(/ListName)
(Get)SubScriptions(/Get)
(/Parameters)
(/Request)
(/API)
(/MDaemon)

Asnwers comes back as :
(?xml version="1.0" encoding="utf-8"?)
(MDaemon)
    (API)
        (Request version="20.0.0" echo="1" verbose="0")
            (Operation)
                GetListInfo
            (/Operation)
            (Parameters)
                (Domain)
                    domainName
                (/Domain)
                (ListName)
                    testu
                (/ListName)
                (Get)
                    Membership
                (/Get)
            (/Parameters)
        (/Request)
        (Response version="20.0" session="E310DC13" et="0.001028")
            (Status id="0" value="0x00000000" message="L’opération a réussi."/)
            (ServiceVersion)
                20.0.4.1
            (/ServiceVersion)
            (Result)
                (List id="testu@domainName"/)
            (/Result)
        (/Response)
    (/API)
(/MDaemon)

What I am doing wrong, in order to get the list of email addresses subscribed to the ML. I have tried some other Get orders (Detail, Expansion), all get me the same kind of results.

PS : it took me a while to figure out the proper URL to get a response from MDeamon. So I am using : https//myemailserverFQDNName:446/MdMgmtWS/API is the the proper way of formatting the URL ?

  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Stephane BARTHES - Mar 12, 2021 10:03 am (#1 Total: 7)  

 

Photo of Author
Stephane BARTHE…
Newbie
Newbie
Posts: 5
Ok, I found the answer to this question while browsing other xml api topics :
the (get) node must embed other nodes like (Details) or (Membership), and not simple strings.

I can now get the my users from a ML.



  (newer msg:6)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.