Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Support > Archive > Problem receiving mails from powershell scripts

Ayuntamiento de Cuellar

Which Alt-N products do you use?

Most recent posts: Ayuntamiento de Cuellar

Random problem with webmail - 07:18am Jun 17, 2022 CDT - Hello

     I have Mdaemon PRO v21.5.2 and I've been using it for many years.

     From some months we have a random problem with webmail. Some days
the users complains about the slow behavior of worldclient...

Problem receiving mails from powershell scripts - 05:31pm Dec 8, 2021 CDT - Ok, Arron

Thank you very much

Best regards

--

Jorge


El 8/12/21 a las 21:30, Arron Caruth (Arron.Caruth@mdaemon.com) escribió:

> Yes, in many cases I found that adding a delay after sending the
> message would allow the email to send correctly.
>
>
> --
> *Arron Caruth*
> Vice President of Product Development
> *o*: 817-601-3222 *e*: Arron.Caruth@mdaemon.com
>
> *M*Daemon Technologies
> Simple Secure Email
>
> Visit us on www.mdaemon.com <www.mdaemon.com> | Facebook
> <https://www.facebook.com/MDaemon.Technologies/> | LinkedIn
> <https://www.linkedin.com/company/mdaemon-technologies> | YouTube
> <https://www.youtube.com/c/MDaemonTechnologies>
> Sent using the MDaemon Email Server <http://www.mdaemon.com/>
>
> On Wed, 8 Dec 2021 19:38:36 +0100, "informatica@aytocuellar.es
> (Jorge Redondo)" <informatica@aytocuellar.es> wrote:
> Hi Arron
>
>      The script is running in other machines different from the
> Mdaemon
> server.
>
>      The powershell command is embedded in a batch script:
>
> c:\windows\System32\WindowsPowerShell\v1.0\powershell.exe ^
>         Send-MailMessage -From 'sender@domain.com
> <mailto:sender%40domain.com>' -To
> 'receiver@domain.com <mailto:receiver%40domain.com>' ^
>                   -Subject ('This is the subject')          ^
>                   -Body ('This is the body')     ^
>                   -SmtpServer 'mdaemon.domain.com'
>
>      I've done some tests more and I think the send-mailmessage
> command
> doesn't close the connection correctly...

Problem receiving mails from powershell scripts - 01:38pm Dec 8, 2021 CDT - Hi Arron

     The script is running in other machines different from the Mdaemon
server.

     The powershell command is embedded in a batch script:

c:\windows\System32\WindowsPowerShell\v1.0\powershell.exe ^
        Send-MailMessage -From 'sender@domain.com' -To
'receiver@domain.com'   ^
                  -Subject ('This is the subject')          ^
                  -Body ('This is the body')     ^
                  -SmtpServer 'mdaemon.domain.com'

     I've done some tests more and I think the send-mailmessage command
doesn't close the connection correctly.

First, I added a "Test-Connection mdaemon.domain.com -count 1" command
after send-mailmessage...

Problem receiving mails from powershell scripts - 05:34pm Dec 8, 2021 CDT - Hello

I use the powershell command "Send-MailMessage" to send emails from scripts to Mdaemon server v21.5.0.

The command are executed without problem, but the mails aren't be received in the receivers accounts.

In the Mdaemon server the SMTP-In log shows the next error in the log of the smtp sessions:

Socket error sending response to DATA * Socket error 10054 - ¡La conexión ha sido restablecida por otro lado!..

Problem with "lost" inbound messages - 07:36am May 6, 2021 CDT - Hello

     I've discovered a problem in Mdaemon:

     I have a account <user1> which has enabled the option for
forwarding all its inbound emails to another account <user2> (Accounts
Manager | Select account <user1> | Edit | Forwarding | "Enable mail
forwarding" ).

     This forward woks fine with the most of emails. But if an email for
<user1> is classified as spam, the email "disappears"...

OK


You are visiting as a Guest user.