Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon API > MD_SetAutoRespInfo and MD_GetAutoRespInfo

Charl Pohlmann

Which Alt-N products do you use?

Most recent posts: Charl Pohlmann

MD_SetAutoRespInfo and MD_GetAutoRespInfo - 06:09am Jul 22, 2019 CDT - Hello Keith,

Can you please explain how the COM user API is used to set the schedule on an AutoResponse?

Although the MD-API.html file talks about the autoresponse structure, which includes the fields for setting the schedule, this is nowhere to be found in the COM library.

struct MD_AutoResponder
{
  bool Enabled,
  char Script[MAX_PATH+1],
  char Process[MAX_PATH+1],
  char Exclude[AUTORESPEXCLUDE_LEN+1],
  char AddToList[EMAIL_LEN+1],
  char RemoveFromList[EMAIL_LEN+1],
  char StartTime[TIME_LEN+1], (== missing in COM library
  char EndTime[TIME_LEN+1], (== missing in COM library
  bool PassMessage,
  int Days, (== missing in COM library
},

These fields are absent when using the MDUser.SetAutoRespInfo function as explained in MDCOM-API.html

In the attached images you will note that I am using C# to write a plugin, but that the COM function SetAutoRespInfo does not expose any parameters for setting a schedule...

MD_SetAutoRespInfo and MD_GetAutoRespInfo - 08:25am Jun 28, 2019 CDT - Thanks Keith.

I'll post again if I run into any issues.

MD_SetAutoRespInfo and MD_GetAutoRespInfo - 05:25pm Jul 22, 2019 CDT - Good day,

I don't know if I'm just thick, or if there is a mistake in the API documentation, but I would appreciate some help.

The API documentation @ (a href='http://files.altn.com/MDaemon/release/md-api.html#MD_GetAutoRespInfo' target='_new')MD_GetAutoRespInfo(/a) shows the function signature as:
void MD_GetAutoRespInfo(
  MD_HANDLE hUser // handle to a valid account record
  MD_AutoResponder* AutoResponder // pointer to MD_AutoResponder struct
)

but then proceeds to talk about other parameters.

At first I thought that the parameters were simply passed in the same order in which they appear in the structure, but they are not, because the Start and End times are never even specified or passed...

Creating a Plugin using .NET - 06:41am May 23, 2019 CDT - And after spending time writing up the previous post, and previewing it, and making sure that everything is readable etc, only half my posting actually shows up, and ins imply truncated half way through.

This forum is therefore utterly useless and I will not waste any more of my time sharing anything here.

Creating a Plugin using .NET - 06:35am May 23, 2019 CDT - OK, I solved the problem, and I thought I would post the solution here in case somebody else runs into the same issue.
I would also like to point out that I had zero support from anybody at Alt-N, even after requesting support. I was simply pointed back to my own post here and told that Alt-N developers are constantly monitoring this forum, and will provide support here...

OK


You are visiting as a Guest user.