Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Support > Archive > Messages randomly not accessible to random users

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon Support  / Archive  /

Messages randomly not accessible to random users

[Reinoehl, Parrish]
Parrish Reinoeh…
Newbie
Newbie
Posts: 22
Parrish Reinoehl - 10:29pm, Feb 28 2020

I'm having a very strange problem that we haven't been able to resolve. I have been working with Alt-N support but we can't nail down the cause.
So, hopefully, someone here might have some ideas.
We are running Mdaemon 19.5.4 on a Server 2012 box. It is a 32bit install.
We are having an issue where a random user is unable to access their messages either via IMAP or Webmail. The user that is affected appears to be completely random. The frequency of this happening seems to be a few times per week.
What they will notice is that Outlook will stop receiving new messages. They can send messages without any issue. If they log in via Webmail it will allow them to log in but it will not display any messages (although it does show the total number of messages present in the account). When I look at the Mdaemon sessions I can see they are logged in so this is not an issue with the user or IP being blacklisted (and I have verified their IP address is not showing up in any blacklists).
I have to stop and then restart the Mdaemon service. As soon as I do that, and immediately after Mdaemon starts back up, all of their emails will load in to Outlook (Outlook is configured using IMAP). Webmail will also now display all of their messages.
I have verified that the entire Mdaemon directory and subdirectories are excluded from the antivirus (which is Avast CloudCare). The user folders are in their standard location within the Mdaemon directory and it is located on the C: drive of the server (so not on a NAS or anything like that).
I have sent various log files to Alt-N support but nothing is showing up as being a problem.
My users are growing extremely impatient with this. Does anyone have any ideas of what else I should be looking at?
This customer was previously on an old version, 16.5, and was experiencing this issue maybe once per month or so. I renewed their Mdaemon support contract so we could upgrade them to 19.5.4 in the hopes it would resolve the trouble. But, in actuality, it's made the trouble much more prominent as it now happens a few times (or more) per week.

  (older msg: 2)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Arron Caruth - Mar 26, 2020 12:23 pm (#3 Total: 24)  

Guest User  

Photo of Author
Posts: 1

Lets focus in on this one user and see if we can figure out what is going on.

 

Is the user using IMAP to access their account?

 

Are they accessing their account any other way, such as Webmail, MDaemon Connector, ActiveSync, etc?

 

Can you send me the logs for all protocols being used to access the account included the time the LCK file was created?

 

Approximately what time was the LCK file created?

 

What time was it when you removed the LCK file?

 

Are there any disk errors in the Windows Event Viewer?

 

--
Arron Caruth
Vice President of Product Development
o: 817-601-3222    e: Arron.Caruth@mdaemon.com

MDaemon Technologies
Simple Secure Email
Visit us on www.mdaemon.com | Facebook | LinkedIn | YouTube
Sent using the MDaemon Email Server

From: md-support@mdaemon.com [mailto:md-support@mdaemon.com] On Behalf Of Parrish Reinoehl
Sent: Thursday, March 26, 2020 11:34 AM
To: md-support@mdaemon.com
Subject: [md-support] Messages randomly not accessible to random users

 

Thanks Arron.
This issue hadn't happened for few weeks so I thought it may have been resolved. But it happened again today. I did check for a .lck file on the LockFiles folder. And you are correct. There was a .lck file there for the affected user and it was for their Inbox. As soon as I deleted that .lck file their emails immediately started to populate in Outlook.
What should I check to try and determine why the .lck file isn't automatically being removed? In this case the file was about 3 hours old.


View/reply at Messages randomly not accessible to random users

 
 
--MD-SUPPORT--------------------------------------------------------------
This list is for questions and discussion about MDAEMON. To unsubscribe 
from this mailing list send an email to md-support-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!-----------------------------------------------------
 
--------------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/Support/RequestSupport/
--------------------------------------------------------------------------

--MD-SUPPORT--------------------------------------------------------------
This list is for questions and discussion about MDAEMON. To unsubscribe 
from this mailing list send an email to md-support-unsubscribe@mdaemon.com .
--POWERED BY MDAEMON!-----------------------------------------------------

--------------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user 
support and discussion.  MDaemon staff members may participate in the 
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical 
support please use the form here:
http://www.mdaemon.com/Support/RequestSupport/
--------------------------------------------------------------------------

Parrish Reinoehl - Apr 20, 2020 3:03 pm (#4 Total: 24)  

 

Photo of Author
Parrish Reinoeh…
Newbie
Newbie
Posts: 22
Hi Aaron,
I apologize for not responding sooner. I was waiting until this trouble happened again so I could collect the files you need. It hadn't happened in some time but did happen again this morning for one of the users. I'm sending you an email with the lck and log files as a zip attachment.
Hopefully this will have what you need to help track down what may be causing this.

Thanks!



  (newer msg:20)All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.